jQuery 1.11.2 et 2.1.3 sont disponibles et améliorent la compatibilité inter navigateurs
La bibliothèque JavaScript prépare sa version 3

Le , par danielhagnoul, Rédacteur
jQuery 1.11.2 et 2.1.3 sont disponibles
Correction des bogues de Safari 7.1 et 8.0.

Ces mises à jour comprennent plusieurs corrections de bogues pour améliorer la compatibilité internavigateurs. Le bogue le plus grave est causé par la fonction querySelectorAll dans Safari. Apple n'ayant pas encore fixé une date pour la correction de cette faille. Même les navigateurs modernes peuvent souffrir de bogues pendant une longue période, jQuery vous permet de continuer à écrire un code unique pour tous les navigateurs.

Plusieurs améliorations du code de jQuery permettent de diminuer la charge de travail du DOM, dans le but d'améliorer la vitesse de traitement et d'utiliser moins de mémoire.

Dans la branche 2, ne cherchez pas la version 2.1.2, elle n'existe plus. Elle était la cause d'un grave problème dans node. Pour ne pas polluer les autres serveurs de codes (CDN) avec une version défaillante, la version 2.1.3 succède à la 2.1.1.

Sauf imprévu (bogues importants), il s'agit des dernières mises à jour pour les branches 1 et 2 avant l'arrivée de la branche 3.

Serveur de code (CDN) jQuery :
  • "https://code.jquery.com/jquery-1.11.2.js"
  • "https://code.jquery.com/jquery-2.1.3.js"


Téléchargement

Source


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :
Offres d'emploi IT
Développeur javascript innovation first
Adequat Tertiaire - Rhône Alpes - Grenoble (38000)
Leader Technique Front-End PHP Javascript
Lyon Tertiaire ADEQUAT - Rhône Alpes - Grenoble
Développeur javascript innovation first
Adequat Tertiaire - Rhône Alpes - Grenoble (38000)

Voir plus d'offres Voir la carte des offres IT
Responsable bénévole de la rubrique JavaScript : Xavier Lecomte -