jQuery UI 1.8 est disponible
Comprenant 5 nouveaux plug-ins, 1 nouvel effet, et des centaines de corrections de bogues et d'améliorations

Le , par danielhagnoul, Rédacteur
2010-06-10 : jQuery UI 1.8.2 est disponible

Cette mise à jour apporte des corrections de bugs aux widgets Selectable, Sortable, Accordion, Autocomplete, Button, Datepicker et Slider.

Pour la liste complète des modifications, voir : http://jqueryui.com/docs/Changelog/1.8.2

Téléchargements des Fichiers : http://jqueryui.com/download

Source : http://blog.jqueryui.com/
----------

2010-05-06 : jQuery UI 1.8.1 est disponible

Cette mise à jour apporte plusieurs corrections au widget AutoComplete et quelques correctifs à d'autres widgets.

Pour la liste complète des modifications, voir http://jqueryui.com/docs/Changelog/1.8.1.
----------

jQuery UI 1.8 est disponible

L'équipe de jQuery UI annonce la sortie de jQuery UI 1.8, cette version apporte 5 nouveaux plug-ins, 1 nouvel effet, et des centaines de corrections de bogues et d'améliorations.

Pour une liste complète de tous les changements entre jQuery UI 1.7.2 et jQuery UI 1.8, voir le Changelog 1.8.

Les développeurs ont travaillé très dur pour rendre jQuery UI plus léger et plus modulaire avec un noyau encore plus flexible et extensible. Il est désormais encore plus facile de créer vos propres widgets ou d'étendre ceux de jQuery UI, si vous utilisez l'interface utilisateur JQuery Widget Factory, la jQuery UI CSS Framework, ou les deux.

Le code, les thèmes, les démos, et la documentation sont maintenant en ligne sur jqueryui.com, le jQuery UI Download Builder , ThemeRoller, et les bibliothèques de Google AJAX API.

Télécharger jQuery UI 1.8

Le jQuery UI 1.8 Starter Pack contient tous les composants et le thème par défaut. Il est optimisé pour une utilisation avec le guide de démarrage, cette version est recommandée aux nouveaux utilisateurs.

Le jQuery UI 1.8 Themes Pack contient les 21 thèmes de la ThemeRoller Gallery.

Le jQuery UI 1.8 Download Builder peut créer un zip personnalisé avec uniquement les composants et le thème personnalisé que vous sélectionnez. Elle s'occupe également des dépendances de plug-in.

Nota Bene : les développeurs ont connaissance de l’existence de problèmes lorsque l’on utilise jQuery UI 1.7.2 avec JQuery 1.4.2. Ces versions ne sont pas compatibles. La prochaine version de la branche 1.7, jQuery UI 1.7.3, sera compatible avec jQuery 1.4.2. Ce sera la dernière version 1.7.x.

Source : http://blog.jqueryui.com/


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de RPGamer RPGamer - Membre actif https://www.developpez.com
le 24/03/2010 à 14:57
Merci pour l'information.

Dans mon cas, je gagne quelques 11 Ko sur le fichier construit. Cette version est-elle compatible avec jQuery 1.4.2 ?
Avatar de danielhagnoul danielhagnoul - Rédacteur https://www.developpez.com
le 24/03/2010 à 19:18
Bonsoir.

Citation Envoyé par RPGamer  Voir le message
Merci pour l'information.

Dans mon cas, je gagne quelques 11 Ko sur le fichier construit. Cette version est-elle compatible avec jQuery 1.4.2 ?

Oui !
Avatar de gtraxx gtraxx - Membre confirmé https://www.developpez.com
le 30/03/2010 à 10:32
Je viens de télécharger cette nouvelle version mais je trouve que les importations CSS sont trop nombreuse.
On perd en performance mais bon je vais tout rassembler dans une seule CSS.
Une question c'est normal que la génération d'un thème ne modifie plus les couleurs des images ?
Je continue à tester avant de faire une vrai mise à jour de mes applis.
Avatar de danielhagnoul danielhagnoul - Rédacteur https://www.developpez.com
le 30/03/2010 à 22:50
Bonsoir.

Le jQuery UI 1.8 Download Builder peut créer un zip personnalisé avec uniquement les composants et le thème personnalisé que vous sélectionnez. Elle s'occupe également des dépendances de plug-in.

En utilisant cette méthode, en téléchargeant la totalité, vous aurez une page avec un seul appel pour le CSS et un seul appel pour le JS. Exemple, ma page type :
Code : Sélectionner tout
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
<!doctype html> 
<html lang="fr"> 
<head> 
	<meta charset="utf-8"> 
	<meta name="Author" content="Daniel Hagnoul"> 
	<meta name="description" content="Page type"> 
	<title>Page type</title> 
	<link rel="stylesheet" type="text/css" href="../lib/jqueryui-1.8/css/humanity/jquery-ui-1.8.custom.css">	 
	<style> 
		body { 
			background-color:#dcdcdc; 
			color:#000000; 
			font-family:sans-serif; 
			font-size:medium; 
			font-style:normal; 
			font-weight:normal; 
			line-height:normal; 
			letter-spacing:normal; 
		} 
		h1,h2,h3,h4,h5 { 
			font-family:serif; 
		} 
		div,p,h1,h2,h3,h4,h5,h6,ul,ol,dl,form,table,img { 
			margin:0px; 
			padding:0px; 
		} 
		p { 
			padding:6px; 
		} 
		ul,ol,dl { 
			list-style:none; 
			padding-left:6px; 
			padding-top:6px; 
		} 
		li { 
			padding-bottom:6px; 
		} 
		div#conteneur { 
			width:95%; 
			margin:12px auto; 
			padding:6px; 
			background-color:#FFFFFF; 
			color:#000000; 
			border:1px solid #666666; 
			font-size:0.8em; 
		}		 
		div#affiche { 
			margin:12px; 
			padding:6px; 
			border:1px solid #999999; 
			background-color:#FFFFFF; 
			color:#000000; 
		} 
		 
		/* TEST */ 
	</style> 
	<script charset="utf-8" src="../lib/jqueryui-1.8/js/jquery-1.4.2.min.js"></script> 
	<script charset="utf-8" src="../lib/jqueryui-1.8/js/jquery-ui-1.8.custom.min.js"></script> 
	<script> 
		$(function(){ 
		}); 
	</script> 
</head> 
<body> 
	<div id="conteneur"> 
	</div> 
</body>   
</html>
Avatar de gtraxx gtraxx - Membre confirmé https://www.developpez.com
le 01/04/2010 à 13:13
Un seul appel certes mais avec importation multiple.
Mais bon je vais continuer à vérifier si tout va bien chez moi avant upgrade
Avatar de danielhagnoul danielhagnoul - Rédacteur https://www.developpez.com
le 06/05/2010 à 22:33
Cette mise à jour apporte plusieurs corrections au widget AutoComplete et quelques correctifs à d'autres widgets.

Pour la liste complète des modifications, voir http://jqueryui.com/docs/Changelog/1.8.1.
Avatar de danielhagnoul danielhagnoul - Rédacteur https://www.developpez.com
le 11/06/2010 à 1:29
Cette mise à jour apporte des corrections de bugs aux widgets Selectable, Sortable, Accordion, Autocomplete, Button, Datepicker et Slider.

Pour la liste complète des modifications, voir : http://jqueryui.com/docs/Changelog/1.8.2

Téléchargements des fichiers : http://jqueryui.com/download

Source : http://blog.jqueryui.com/
Offres d'emploi IT
Lead développeur fullstack django/rest/javascript
Mobiskill - Ile de France - Paris (75000)
Développeur javascript innovation first
Adequat Tertiaire - Rhône Alpes - Grenoble (38000)
Un(e) développeur(se) javascript
Bubblz - Ile de France - Paris (75000)

Voir plus d'offres Voir la carte des offres IT
Responsable bénévole de la rubrique JavaScript : Xavier Lecomte -