Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

AngularJS 1.7 annoncé avec la mise en LTS du framework
Période qui va s'achever dans 3 ans et demi !

Le , par Marco46

22PARTAGES

7  0 
Le 26 janvier dernier, Pete Bacon Darwin un des core développeurs de la team Angular, a annoncé la sortie de la version 1.7 du framework sur le blog Angular qui héberge depuis juillet 2017 les news concernant les deux frameworks de Google.


Depuis octobre 2017, le trafic sur la documentation du nouveau Angular a dépassé le trafic de la documentation de AngularJS. Dès la ng-conf 2015, Google avait annoncé que le support actif de AngularJS existerait tant que le trafic sur AngularJS serait supérieur à celui du site de Angular.


C'est désormais chose faite, et après une dernière itération dont l'avancée de la milestone peut être consultée sur github, le framework entrera dans une phase de Long Term Support pour une durée de trois ans à compter de la sortie de la version 1.7.0.

Les dates sont donc les suivantes :

- Du 1er janvier 2018 au 30 juin 2018, développement actif de la version 1.7.0
- À compter du 1er juillet 2018 jusqu'au 30 juin 2021, période de LTS

Durant cette période, tous les CDN et packages sur npm ou bower gérés par Google seront disponibles.

Les critères conduisant à une livraison au cours du LTS ont été précisés par Pete Bacon Darwin :

- une faille de sécurité ;
- une mise à jour d'un navigateur majeur empêchant l'exécution correcte du framework ;
- une mise à jour de jQuery empêchant l'exécution correcte du framework.

Source : Blog Angular officiel

Et vous ?

Utilisez-vous toujours AngularJS ?
Avez-vous envisagé une migration vers Angular ou une réécriture complète vers un autre framework ?

Une erreur dans cette actualité ? Signalez-le nous !