Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

RequireJS 2.1.7 et 2.1.8 :
Utilisation de l'API du parseur Reflect au lieu de Esprima

Le , par vermine

0PARTAGES

2  0 
Sortie de RequireJS 2.1.7


RequireJS est une bibliothèque JavaScript qui gère le chargement de modules et de fichiers JavaScript. Il est optimisé pour une utilisation dans le navigateur, mais il peut être utilisé dans d'autres environnements JavaScript comme Rhino et Node. Il améliore la vitesse et la qualité de votre code.

La révision 2.1.7 comporte par exemple les changements suivants :

  • pour xpcshell, l'optimiseur utilise l'API du parseur Reflect au lieu de Esprima à cause d'une pile particulière utilisée sous Linux et Windows ;
  • le support de source map est mis à jour pour utiliser la syntaxe //#.


La liste complète des modifications est disponible pour require.js et pour l'optimiseur.

Téléchargement.

Source : l'article de James Burke.

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de vermine
Responsable Jeux-Concours https://www.developpez.com
Le 12/07/2013 à 14:42
Sortie de RequireJS 2.1.8


James Burke sort la révision 2.1.8 pour corriger un petit bogue.

parse.nodeToString calculait de manière incorrecte les intervalles. En résumé, s'il n'y avait aucun commentaire ou contenu au-dessus de l'appel de requirejs.config, il calculait mal la valeur de départ. Maintenant, ce comportement est corrigé.

Téléchargement.

Source : l'article de James Burke.
2  0