Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Sortie de RequireJS 2.1.10 :
La gestion des identifiants de modules

Le , par vermine

0PARTAGES

3  0 
Sortie de RequireJS 2.1.10


James Burke sort la révision 2.1.10 qui est principalement une version de maintenance. Elle améliore certains cas lors de la réutilisation de code ayant été installés par l'intermédiaire de npm. Il y a également deux nouvelles options pour le loader :

  • nodeIdCompat : cette option permet d'utiliser indifféremment les id de modules exemple.js et exemple pour les modules installés par npm ;
  • bundles : cette option permet de pointer plusieurs id de modules vers un id de module qui contient un ensemble de modules.


Les autres améliorations sont décrites ici.

Du côté de l'optimiseur, l'option mainConfigFile peut prendre maintenant un tableau de chemins d'accès vers des fichiers de configuration. Les autres améliorations sont décrites ici.

Téléchargement.

Source : l'article de James Burke.

Une erreur dans cette actualité ? Signalez-le nous !